New Foxit Reader version fixes security issues

The security update for the PDF viewer fixes 13 vulnerabilities.

With the new version Foxit Reader 10.1 and Foxit PhantomPDF 10.1, the manufacturer Foxit Software closes some serious security vulnerabilities in these PDF tools.

There is also a new beta version of the optional 3D plug-in available, which makes three-dimensional content in PDF documents more accessible.

Foxit Reader offers a leaner alternative to the increasingly bloated Acrobat Reader.

The most important reason to update to the new version are security issues of previous versions. These have been addressed with the new version. In the current security bulletin, the manufacturer lists a total of 13 vulnerabilities. Around half of the gaps offer the possibility that an attacker can import and execute code with a prepared PDF document. The vulnerabilities affect Foxit Reader 10.0.1.x and previous versions.

The optionally available 3D plug-in for Foxit Reader is also available in a new beta version. It now has the version number 10.1.0.37494. The manufacturer has fixed five security vulnerabilities. These could also be used by an attacker to inject and execute code. Foxit Software recommends updating Foxit Reader first, and afterwards updating the plug-in.

Read more in the security bulletin.

Update your Foxit applications to the latest versions via the Help tab of Foxit Reader or Foxit PhantomPDF, click on Check for Updates and update to the latest version.


Foxit Reader on UpdateStar | Download

Foxit PhantomPDF on UpdateStar | Download

about author